need help with G11 and strobe

Ask about gear, cameras, lenses, technique or lighting

Moderators: tswinner, bvanant

Postby fishnerd » Wed Dec 08, 2010 10:29 am

Hi- I'm a very novice u/w photographer. I just recently got a canon g11. I have an old sea and sea ys90 dx strobe that says it shoots ttl. I put the camera in AV mode, strobe in ttl mode. I have a fiber optic cable attached. According to the strobe manual a green light is supposed to come on when it's in TTL. I only get a red light. The strobe does fire, but I don't think it's on TTL.
any help you can offer would be greatly appreciated. we leave for a dive trip in 13 days and I'm trying to figure this out.
thanks!
fishnerd
fishnerd
 
Posts: 2
Joined: Thu Sep 30, 2010 8:40 am

Postby smb2 » Wed Dec 08, 2010 9:09 pm

I am not the best person to answer this question.
The Red LED is the ready lamp and lights up when charging is complete.
The green LED will show up for three seconds (in TTL) if the flash and camera have what it feels to be the correct exposure.
If the subject is "out of the proper strobe to subject range", the strobe will fire but you will not see the green light. You may then have an over or under exposed image. Check your distance to the subject and/or f stop.
Alternatively, as many might suggest on this site, set the camera and strobe on manual and adjust accordingly. After all you can review your image and histogram and make pretty quick corrections, with a relatively short learning curve.
Hopefully, somebody with a little more Sea and Sea hands on knowledge will post behind me. :?
User avatar
smb2
 
Posts: 188
Joined: Thu May 13, 2010 5:50 am
Location: Alexandria, Virginia

Postby scottg » Mon Dec 13, 2010 9:05 pm

it will not shoot it TTL, you have to use it in Manual mode. sorry!

Scott Gietler Owner/Editor, Underwater Photography Guide & Bluewater Photo http://www.uwphotographyguide.com http://www.bluewaterphotostore.com

User avatar
scottg
Site Admin
 
Posts: 491
Joined: Sun May 09, 2010 10:31 am
Location: Marina del rey, CA

Postby fishnerd » Tue Dec 14, 2010 6:07 pm

Thanks so much for your input. I did some retail therapy this weekend and bought a new strobe that does shoot ttl and is much newer and more compact, and a wide angle lens. I leave in 7 days for Puerto Galera, Philippines. I can't wait - clearly I need lots and lots of practice!
Pec
fishnerd
fishnerd
 
Posts: 2
Joined: Thu Sep 30, 2010 8:40 am


Return to Underwater Photography Questions

Who is online

Users browsing this forum: No registered users and 5 guests

cron