new wide lens , 20min pool session, residue on lens.

Ask about gear, cameras, lenses, technique or lighting

Moderators: tswinner, bvanant

Postby matsky » Wed Mar 21, 2012 6:20 am

Hi I have a new ikelite lens I wanted to try it out so took it in local pool for 20 mins . It now has a residue that i cannot get rid of , the lens is totaly unusable , I have tried lens cleaner . doesn't make even the slightest difference , i used it for the first ime with new ikelite housing also , the back of the wide angle lens is perfect also the front of the housing lens , so i cant see how it is something in the pool . I wondered if it was some residue from manafacture reacting with chlorine ??? I have emailed Ikelite , they say post it back to them in the usa 50 dolar repair cost and postage to pay !!! Its not that easy as I am in thailand , My original set up was lost by a customer , and he was good enough to buy all new kit in Hong kong where he lives and posted it out to me .so i have no receipts and also feel bad about even telling the poor guy who was good enough to replaace all my 3 year old kit (I had Inon fish eye and cannon housing before) .If anyone has any sugestions as to how i could shift this residue i would be realy gratefull , I am here for another 5 weeks and would love to be able to try the w20 lens out !!!! befor i return to the uk ....
matsky
 
Posts: 1
Joined: Wed Mar 21, 2012 1:16 am

Postby bvanant » Thu Mar 22, 2012 6:33 pm

Which lens? If it is the wide angle lens then I am quite sure that the pool didn't hurt it unless there was something very bad in the pool.
Bill

Bill Van Antwerp Canon/Nauticam/Subal/Inon Lots of glass


Technical Advisor to Bluewater Photo


http://www.blueviews.net

User avatar
bvanant
 
Posts: 309
Joined: Wed May 12, 2010 4:16 pm
Location: Los Angeles (more or less)


Return to Underwater Photography Questions

Who is online

Users browsing this forum: No registered users and 4 guests